added our own pkg-config wrapper, making the sed foo on *.pc files obselete 2/2
[openwrt/svn-archive/archive.git] / libs / howl / Makefile
index f5c3dfabf52dc6e168224311cff5d991be93d0d8..618e4da7d59fd4cd1ddd8d76945c29525c70e9c9 100644 (file)
@@ -101,8 +101,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{howl,mDNSResponder}.{a,so*} $(STAGING_DIR)/usr/lib/
        mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/howl.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I/usr/include,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
-       $(SED) 's,-L/usr/lib/howl,,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
+       $(SED) 's,-I/usr/include,-I$$$${includedir},g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
+       $(SED) 's,-L/usr/lib/howl,-L$$$${libdir}/howl,g' $(STAGING_DIR)/usr/lib/pkgconfig/howl.pc
 endef
 
 define Build/UninstallDev