[packages] howl: add libpthread dependency (#6530)
[openwrt/svn-archive/archive.git] / libs / howl / Makefile
index 48e10c13730a86470d79017457e9ce864ac96e7f..961760ab11b439d2e7d98636a3dd6dc33858f6b2 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -50,7 +49,7 @@ endef
 
 define Package/howl-mdnsresponder
   $(call Package/howl/Default)
-  DEPENDS:=+libhowl
+  DEPENDS:=+libhowl +libpthread
   TITLE:=An mDNS (Multicast DNS) service responder daemon
 endef
 
@@ -99,11 +98,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/howl $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{howl,mDNSResponder}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/howl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-I/usr/include,-I$$$${includedir},g' $(1)/usr/lib/pkgconfig/howl.pc
        $(SED) 's,-L/usr/lib/howl,-L$$$${libdir}/howl,g' $(1)/usr/lib/pkgconfig/howl.pc