[package] update libiksemel to 1.4 (#6250)
[openwrt/svn-archive/archive.git] / libs / iksemel / Makefile
index 388c469909f5937613c72028170ff0d49d7066d3..08dc7cb668a98b5bc01a7255ce95be5575f8c216 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iksemel
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iksemel
-PKG_VERSION:=1.3
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://iksemel.googlecode.com/files/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://iksemel.googlecode.com/files/
-PKG_MD5SUM:=36ab2d9f11980a19217b6f79a19ef8e7
+PKG_MD5SUM:=532e77181694f87ad5eb59435d11c1ca
 
 PKG_FIXUP = libtool
 
 
 PKG_FIXUP = libtool
 
@@ -25,7 +24,14 @@ define Package/libiksemel
   CATEGORY:=Libraries
   TITLE:=Iksemel Jabber Library
   URL:=http://code.google.com/p/iksemel/
   CATEGORY:=Libraries
   TITLE:=Iksemel Jabber Library
   URL:=http://code.google.com/p/iksemel/
-  DEPENDS:= +libgnutls
+  DEPENDS:= +libgnutls +libtasn1
+endef
+
+define Package/libiksemel/description
+  Iksemel is an XML parser library mainly designed for Jabber applications.
+  It provides SAX, DOM, and special Jabber stream APIs. Library is coded
+  in ANSI C except the network code (which is POSIX compatible), thus
+  highly portable.
 endef
 
 TARGET_CFLAGS += $(FPIC)
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -36,7 +42,7 @@ CONFIGURE_ARGS += \
        --with-libgnutls-prefix="$(STAGING_DIR)/usr" \
 
 CONFIGURE_VARS += \
        --with-libgnutls-prefix="$(STAGING_DIR)/usr" \
 
 CONFIGURE_VARS += \
-       LIBS="-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib -lgnutls -lgcrypt -lgpg-error" \
+       LIBS="$(TARGET_LDFLAGS) -Wl,-rpath-link,$(STAGING_DIR)/usr/lib -lgnutls -lgcrypt -lgpg-error" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install