[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / libs / jpeg / Makefile
index 547a90966d94cf14b2dc481e284bf193a32cd594..c741118df0bf14cd10471a7da22396fa867b7f19 100644 (file)
@@ -72,11 +72,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/jpeglib.h $(1)/usr/include/
        $(CP) $(PKG_BUILD_DIR)/jpegint.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/j{config,error,morecfg}.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjpeg.{a,so*} $(1)/usr/lib/
 endef