fftw3: add missing dependency
[openwrt/svn-archive/archive.git] / libs / libaio / Makefile
index d8cc4fd52ac4937a56e588bf8d360c463a7eb052..dc467eaddf2628ad995f66cb8a287a20cb2331c5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libaio
 PKG_VERSION:=0.3.107
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/liba/libaio/
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/libaio
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=@LINUX_2_6
   TITLE:=Linux kernel AIO interface access library
   URL:=http://lse.sourceforge.net/io/aio.html
 endef
@@ -28,7 +27,7 @@ endef
 define Build/Configure
 endef
 
-LIBAIO_CFLAGS:=-nostdlib -nostartfiles -I. $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
+LIBAIO_CFLAGS:=-nostdlib -nostartfiles -I. $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)
 
 TARGET_CFLAGS += $(FPIC)