[packages] massive: use $(INSTALL_DIR) instead of 'mkdir -p' in install and InstallDev
[openwrt/svn-archive/archive.git] / libs / libao / Makefile
index 76c9575087c15c77e10c542a2fa1bcaba6604e5f..a448e25518a0dd1cf1facf3807f968cc01bb3ed3 100644 (file)
@@ -1,20 +1,19 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libao
-PKG_VERSION:=0.8.6
+PKG_VERSION:=0.8.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ao/
-PKG_MD5SUM:=12e136a4c0995068ff134997c84421ed
+PKG_MD5SUM:=b92cba3cbcf1ee9bc221118a85d23dcd
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,20 +26,19 @@ define Package/libao
 endef
 
 define Package/libao/description
-       Libao is a cross-platform audio library that allows programs to 
+       Libao is a cross-platform audio library that allows programs to
        output audio using a simple API on a wide variety of platforms.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-esd \
-               --disable-arts \
-               --disable-nas \
-               --disable-polyp \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-esd \
+       --disable-arts \
+       --disable-nas \
+       --disable-pulse
+
+TARGET_CFLAGS += $(FPIC)
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -49,11 +47,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ao $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libao.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/ao.pc $(1)/usr/lib/pkgconfig/
 endef