lots of package cleanups/fixes
[openwrt/svn-archive/archive.git] / libs / libart / Makefile
index 5288b630a46bd0b8acc516d6145a5e5bb6213ba4..2af3c678e7ba8174bc0c9a76316d866fb393ff52 100644 (file)
@@ -12,13 +12,13 @@ PKG_NAME:=libart
 PKG_VERSION:=2.3.17
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3
 PKG_MD5SUM:=f1f6b3e5490f382535dccb288f5d8b14
-PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,78 +26,39 @@ define Package/libart
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An high-performance 2D graphics library
-  DESCRIPTION:=An high-performance 2D graphics library.\\\
-    A library of functions for 2D graphics supporting a superset of the \\\
-    PostScript imaging model, designed to be integrated with graphics, artwork, \\\
-    and illustration programs. It is written in optimized C, and is fully \\\
-    compatible with C++. With a small footprint of 10,000 lines of code, it is \\\
-    especially suitable for embedded applications.
   URL:=http://www.levien.com/libart/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
-               $(TARGET_CONFIGURE_OPTS) \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --sbindir=/usr/sbin \
-                       --libexecdir=/usr/lib \
-                       --sysconfdir=/etc \
-                       --datadir=/usr/share \
-                       --localstatedir=/var \
-                       --mandir=/usr/man \
-                       --infodir=/usr/info \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-                       --enable-shared=yes \
-                       --enable-static=yes \
-                       --disable-rpath \
-       );
+define Package/libart/description
+       A library of functions for 2D graphics supporting a superset of the 
+       PostScript imaging model, designed to be integrated with graphics, artwork, 
+       and illustration programs. It is written in optimized C, and is fully 
+       compatible with C++. With a small footprint of 10,000 lines of code, it is 
+       especially suitable for embedded applications.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                HOSTCC="$(HOSTCC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libart/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libart2-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libart-2.0 $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir}/libart-2.0,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
+       $(INSTALL_DEV) $(1)/usr/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libart2-config $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libart-2.0 $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libart2-config \
-               $(STAGING_DIR)/usr/include/libart-2.0 \
-               $(STAGING_DIR)/usr/lib/libart_lgpl_2.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
+define Package/libart/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libart))