Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / libart / Makefile
index 45d7525ba6275f768095211a67a5799de703b6ad..6ab532f70f82d5a6b75cbe810152a814598012bd 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,32 +9,37 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libart
-PKG_VERSION:=2.3.17
-PKG_RELEASE:=1
+PKG_VERSION:=2.3.20
+PKG_RELEASE:=3
 
-PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ftp.gnome.org/pub/gnome/sources/libart_lgpl/2.3
-PKG_MD5SUM:=f1f6b3e5490f382535dccb288f5d8b14
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
+PKG_MD5SUM:=d0ce67f2ebcef1e51a83136c69242a73
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_lgpl-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_INSTALL=1
+
 define Package/libart
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An high-performance 2D graphics library
-  DESCRIPTION:=\
-       A library of functions for 2D graphics supporting a superset of the \\\
-       PostScript imaging model, designed to be integrated with graphics, artwork, \\\
-       and illustration programs. It is written in optimized C, and is fully \\\
-       compatible with C++. With a small footprint of 10,000 lines of code, it is \\\
-       especially suitable for embedded applications.
   URL:=http://www.levien.com/libart/
 endef
 
+define Package/libart/description
+       A library of functions for 2D graphics supporting a superset of the 
+       PostScript imaging model, designed to be integrated with graphics, artwork, 
+       and illustration programs. It is written in optimized C, and is fully 
+       compatible with C++. With a small footprint of 10,000 lines of code, it is 
+       especially suitable for embedded applications.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -43,31 +48,29 @@ define Build/Configure
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               HOSTCC="$(HOSTCC)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) HOSTCC="$(HOSTCC)"
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libart2-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libart-2.0 $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc $(STAGING_DIR)/usr/lib/pkgconfig/
-       $(SED) 's,-I$$$${includedir}/libart-2.0,,g' $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
-       $(SED) 's,-L$$$${libdir},,g' $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
-endef
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/lib/pkgconfig
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/libart2-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/libart2-config
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libart-2.0 \
+                       $(1)/usr/include/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} \
+               $(1)/usr/lib/
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libart2-config \
-               $(STAGING_DIR)/usr/include/libart-2.0 \
-               $(STAGING_DIR)/usr/lib/libart_lgpl_2.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libart-2.0.pc
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libart-2.0.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libart/install