Retain symlinks. $(INSTALL_*) copys the contens of a file, so if we want to keep
[openwrt/svn-archive/archive.git] / libs / libart / Makefile
index f87a48a1b6729d17895bd0cc8a312cc46ce6657e..6ab532f70f82d5a6b75cbe810152a814598012bd 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libart
 PKG_VERSION:=2.3.20
 
 PKG_NAME:=libart
 PKG_VERSION:=2.3.20
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
 
 PKG_SOURCE:=$(PKG_NAME)_lgpl-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)_lgpl/2.3
@@ -64,8 +64,8 @@ define Build/InstallDev
                $(PKG_INSTALL_DIR)/usr/include/libart-2.0 \
                        $(1)/usr/include/
 
                $(PKG_INSTALL_DIR)/usr/include/libart-2.0 \
                        $(1)/usr/include/
 
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,so*} \
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.{la,a,so*} \
                $(1)/usr/lib/
 
        $(INSTALL_DATA) \
                $(1)/usr/lib/
 
        $(INSTALL_DATA) \
@@ -75,7 +75,7 @@ endef
 
 define Package/libart/install
        $(INSTALL_DIR) $(1)/usr/lib
 
 define Package/libart/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libart_lgpl_2.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libart))
 endef
 
 $(eval $(call BuildPackage,libart))