[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / libs / libcelt / Makefile
index a59592e496d1bd32e362b911de472e3e2b3814bd..f29ccddebc31df278d8307ba03f1ef483ef7ef02 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -15,7 +15,9 @@ PKG_SOURCE:=celt-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/celt-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/celt/
 PKG_MD5SUM:=0bb72abec367f4ef12551f79dda11b23
+
 PKG_BUILD_DEPENDS:=libogg
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,24 +32,18 @@ define Package/libcelt/description
  The CELT codec is an experimental audio codec for use in low-delay speech and audio communication.
 endef
 
-CONFIGURE_ARGS += \
-       --without-ogg
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               LDFLAGS="$(TARGET_LDFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --without-ogg \
+       )
 endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/celt
-       $(CP)   $(PKG_INSTALL_DIR)/usr/include/celt/celt*.h \
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/celt/celt*.h \
                $(1)/usr/include/celt
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP)   $(PKG_INSTALL_DIR)/usr/lib/* \
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* \
                $(1)/usr/lib/
 endef