[package] ahcpd: Fix server mode (broken script)
[openwrt/svn-archive/archive.git] / libs / libconfig / Makefile
index efd0d7626842def24a9b905df0f15913387f2f89..df0562c2c49e39b035fd6f1daaa075dd83fe7936 100644 (file)
@@ -1,20 +1,22 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libconfig
-PKG_VERSION:=1.3
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hyperrealm.com/libconfig/
-PKG_MD5SUM:=00f2ebfacb5a0b7b02b409b751432b80
+PKG_MD5SUM:=3ebfb70dcb0c2ee454cda50fc634f4f2
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +28,15 @@ define Package/libconfig
 endef
 
 define Package/libconfig/description
-       Libconfig is a simple library for manipulating structured 
-       configuration files. This file format is more compact and more 
-       readable than XML. And unlike XML, it is type-aware, so it is not 
      necessary to do string parsing in application code.
-
-       Libconfig is very compact -- just 38K for the stripped C shared 
-       library (less than one-fourth the size of the expat XML parser 
-       library) and 66K for the stripped C++ shared library. This makes 
      it well-suited for memory-constrained systems like handheld devices.
+ Libconfig is a simple library for manipulating structured configuration
+ files. This file format is more compact and more readable than XML. And
+ unlike XML, it is type-aware, so it is not necessary to do string 
+ parsing in application code.
+
+ Libconfig is very compact -- just 38K for the stripped C shared
+ library (less than one-fourth the size of the expat XML parser library)
+ and 66K for the stripped C++ shared library. This makes it well-suited
+ for memory-constrained systems like handheld devices.
 endef
 
 CONFIGURE_ARGS += \
@@ -42,15 +44,10 @@ CONFIGURE_ARGS += \
        --enable-static \
        --disable-cxx
 
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/libconfig/
+       $(INSTALL_DIR) $(1)/usr/include/libconfig/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libconfig.h $(1)/usr/include/libconfig/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.{a,so} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so* $(1)/usr/lib/
 endef