[package] update libconfig to 1.4 (#6238)
[openwrt/svn-archive/archive.git] / libs / libconfig / Makefile
index efd0d7626842def24a9b905df0f15913387f2f89..f60ce08c05972a9d949eda763059cffc243bcd81 100644 (file)
@@ -1,20 +1,19 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libconfig
-PKG_VERSION:=1.3
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hyperrealm.com/libconfig/
-PKG_MD5SUM:=00f2ebfacb5a0b7b02b409b751432b80
+PKG_MD5SUM:=c6b1c6ccb1a35b93ebf771779d915181
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +25,14 @@ define Package/libconfig
 endef
 
 define Package/libconfig/description
-       Libconfig is a simple library for manipulating structured 
-       configuration files. This file format is more compact and more 
-       readable than XML. And unlike XML, it is type-aware, so it is not 
+       Libconfig is a simple library for manipulating structured
+       configuration files. This file format is more compact and more
+       readable than XML. And unlike XML, it is type-aware, so it is not
        necessary to do string parsing in application code.
 
-       Libconfig is very compact -- just 38K for the stripped C shared 
-       library (less than one-fourth the size of the expat XML parser 
-       library) and 66K for the stripped C++ shared library. This makes 
+       Libconfig is very compact -- just 38K for the stripped C shared
+       library (less than one-fourth the size of the expat XML parser
+       library) and 66K for the stripped C++ shared library. This makes
        it well-suited for memory-constrained systems like handheld devices.
 endef