packages: Update s-lang library to 2.2.4
[openwrt/svn-archive/archive.git] / libs / libdbi / Makefile
index f0d2ebf69d5e5bd73114633b92b522859f953311..8bb5159b0ebfd1bdf2be02729a20756789b2e252 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdbi
 PKG_VERSION:=0.8.3
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/libdbi
-PKG_MD5SUM:=
+PKG_MD5SUM:=ca66db78d479cbfa727cf3245b5864ae
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,15 +29,7 @@ define Package/libdbi
 endef
 
 define Package/libdbi/description
-       SQLite is a small C library that implements a self-contained, embeddable, 
-       zero-configuration SQL database engine. This package contains the SQLite
-       (v3.x) shared library, used by other programs.
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       libdbi implements a database-independent abstraction layer in C.
 endef
 
 define Build/InstallDev