packages: ipv6/tayga: move static mappings to 'firewall' config
[openwrt/svn-archive/archive.git] / libs / libdirectfb / Makefile
index 7eddc5590445eaec82e5a21739b8dc7a600079b6..2c4d2ce6f027cb291cc6d90445618dbaabba36d3 100644 (file)
@@ -20,7 +20,7 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/DirectFB
+define Package/directfb
     TITLE:=DirectFB
     SECTION:=libs
     CATEGORY:=Libraries
@@ -28,7 +28,7 @@ define Package/DirectFB
     DEPENDS:=+libpng +libjpeg +libpthread +libfreetype
 endef
 
-define Package/DirectFB/description
+define Package/directfb/description
     DirectFB is a thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system with support for translucent windows and multiple display layers, not only on top of the Linux Framebuffer Device. It is a complete hardware abstraction layer with software fallbacks for every graphics operation that is not supported by the underlying hardware.
 endef
 
@@ -74,10 +74,11 @@ define Build/InstallDev
                $(1)/usr/lib/
 endef
 
-define Package/DirectFB/install
+define Package/directfb/install
        $(INSTALL_DIR) \
                $(1)/usr/bin \
                $(1)/usr/lib \
+               $(1)/usr/share/directfb-1.4.2 \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBFont \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBImageProvider \
                $(1)/usr/lib/directfb-1.4-0/interfaces/IDirectFBVideoProvider \
@@ -87,6 +88,9 @@ define Package/DirectFB/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/bin/* \
                $(1)/usr/bin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/share/directfb-1.4.2/* \
+               $(1)/usr/share/directfb-1.4.2/
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/lib{direct,fusion}*.so* \
                $(1)/usr/lib/
@@ -111,4 +115,4 @@ define Package/DirectFB/install
 endef
 
 $(eval $(call Feature,DirectFB))
-$(eval $(call BuildPackage,DirectFB))
+$(eval $(call BuildPackage,directfb))