[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / libs / libdlna / Makefile
index ef80f5d7a2c92a114a50e62978fca2b1bbea83a6..a8e9f51b638d1dde40f6aebf10bb484c72d4d131 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -36,8 +36,8 @@ endef
 define Build/Configure
        # this is *NOT* GNU configure
        ( cd $(PKG_BUILD_DIR); \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -lfaad -lpthread -lz" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS) -lfaad -lpthread -lz" \
                HOST_CC="$(HOSTCC)" \
                ./configure \
                --cross-compile \