[packages] add liblo - Lightweight Open Sound Control (OSC) implementation
[openwrt/svn-archive/archive.git] / libs / libdnet / Makefile
index 5c6406d6a96465eb0d3f5853bf462186af948873..ec9d1b0cf596b881413a1878cbdb00797d37aa63 100644 (file)
@@ -1,47 +1,53 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libdnet
-PKG_VERSION:=1.10
+PKG_VERSION:=1.11
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=416b765e9d9961501ac85e9a366fd219
+PKG_MD5SUM:=04c394ed8e1e7fc455456e79e908916d
+
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/libdnet
+define Package/libdnet/Default
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Low-level network library
   URL:=http://sourceforge.net/projects/libdnet/
 endef
 
-define Package/libdnet/description
-       libdnet is a library of simplified, portable interface to several 
+define Package/libdnet/Default/description
+       libdnet is a library of simplified, portable interface to several
        low-level networking routines.
 endef
 
+define Package/libdnet
+  $(call Package/libdnet/Default)
+endef
+
+define Package/libdnet/description
+  $(call Package/libdnet/Default/description)
+endef
+
 define Package/pydnet
-  SECTION:=libs
-  DEPENDS:=libdnet python-core
-  CATEGORY:=Libraries
-  TITLE:=Low-level network library
-  URL:=http://sourceforge.net/projects/libdnet/
+  $(call Package/libdnet/Default)
+  DEPENDS:=libdnet +python-mini
 endef
 
 define Package/pydnet/description
-       libdnet is a library of simplified, portable interface to several 
-       low-level networking routines.
+  $(call Package/libdnet/Default/description)
+  This package contains the python dnet library.
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -55,10 +61,6 @@ CONFIGURE_ARGS += \
 CONFIGURE_VARS += \
        ac_cv_dnet_bsd_bpf=no
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-
 define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin
        $(INSTALL_BIN) \