[packages] xyssl: Updated to 0.9
[openwrt/svn-archive/archive.git] / libs / libdvbpsi4 / Makefile
index e767488320cc62332054d612274cf9a9167a47e7..025abfdeb9bb49a6a0b86fc1e6e595897b915579 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.videolan.org/pub/libdvbpsi/$(PKG_VERSION)/
 PKG_MD5SUM:=407cd074b7d6eaf31b20b693ed924655
-PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,12 +25,14 @@ define Package/libdvbpsi4
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=MPEG TS and DVB PSI tables decoding and generating
-  DESCRIPTION:=\
-       libdvbpsi is a simple library designed for MPEG TS and DVB PSI tables \\\
-       decoding and generating. 
   URL:=http://www.videolan.org/developers/libdvbpsi.html
 endef
 
+define Package/libdvbpsi4/description
+       libdvbpsi is a simple library designed for MPEG TS and DVB PSI tables 
+       decoding and generating.
+endef
+
 define Build/Compile
        $(call Build/Compile/Default, \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -40,21 +41,15 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/dvbpsi $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdvbpsi.{a,so*,la} $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/dvbpsi \
-               $(STAGING_DIR)/usr/lib/libdvbpsi.{a,so*,la}
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/dvbpsi $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdvbpsi.{a,so*,la} $(1)/usr/lib/
 endef
 
 define Package/libdvbpsi4/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INTALL_DIR)/usr/lib/libdvbpsi.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libdvbpsi.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libdvbpsi4))