[package] update libelf to 0.8.12 (#5819)
[openwrt/svn-archive/archive.git] / libs / libelf / Makefile
index 7be041581a4318f152ef24badd7151225ba1ca32..7b15bf4c2fa416cbefc6c96e4b873991e5f0dcba 100644 (file)
@@ -1,20 +1,19 @@
-# 
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libelf
-PKG_VERSION:=0.8.10
+PKG_VERSION:=0.8.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mr511.de/software/
-PKG_MD5SUM:=9db4d36c283d9790d8fa7df1f4d7b4d9
+PKG_MD5SUM:=e21f8273d9f5f6d43a59878dc274fec7
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +21,11 @@ define Package/libelf
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=ELF object file access library
-  URL:=http://www.stud.uni-hannover.de/~michael/software/
+  URL:=http://www.mr511.de/software/
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \