[package] fix znc dependency against openssl, bump release number (#5544)
[openwrt/svn-archive/archive.git] / libs / libevent / Makefile
index 262fa063c7fb0a67591ec1abf43e27128ce92e08..38aebe4b8845d05cad2664eb93707e03d21abeb4 100644 (file)
@@ -4,21 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libevent
-PKG_VERSION:=1.1
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable.tar.gz
 PKG_SOURCE_URL:=http://www.monkey.org/~provos/
-PKG_MD5SUM:=a5bd281aeb41bdaa48fbbf0495423d20
-PKG_CAT:=zcat
-
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=5154fd4582d64077d6b17851f04d6957
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,76 +22,45 @@ define Package/libevent
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Event notification library
-  DESCRIPTION:=Event notification library for event-driven network servers.\\\
-    The libevent API provides a mechanism to execute a callback function \\\
-    when a specific event occurs on a file descriptor or after a timeout \\\
-    has been reached. Furthermore, libevent also support callbacks due \\\
-    to signals or regular timeouts.\\\
-    \\\
-    libevent is meant to replace the event loop found in event driven \\\
-    network servers. An application just needs to call event_dispatch() \\\
-    and then add or remove events dynamically without having to change \\\
-    the event loop.
   URL:=http://www.monkey.org/~provos/libevent/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-       );
+define Package/libevent/description
+       The libevent API provides a mechanism to execute a callback function 
+       when a specific event occurs on a file descriptor or after a timeout 
+       has been reached. Furthermore, libevent also support callbacks due 
+       to signals or regular timeouts.
+       
+       libevent is meant to replace the event loop found in event driven 
+       network servers. An application just needs to call event_dispatch() 
+       and then add or remove events dynamically without having to change 
+       the event loop.
 endef
 
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_CFLAGS += $(FPIC)
 
-define Package/libevent/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-$(PKG_VERSION).so.* $(1)/usr/lib/
-endef
+Hooks/InstallDev/Post += libtool_fixup_libdir
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/event.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent.{a,so} $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-$(PKG_VERSION).so* $(STAGING_DIR)/usr/lib/
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+       mkdir -p $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent.{la,a,so} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-1.4.so* $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/event.h \
-               $(STAGING_DIR)/usr/lib/libevent.{a,so} \
-               $(STAGING_DIR)/usr/lib/libevent-$(PKG_VERSION).so*
+define Package/libevent/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-1.4.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libevent))