fix various makefile errors (#1236)
[openwrt/svn-archive/archive.git] / libs / libevent / Makefile
index 262fa063c7fb0a67591ec1abf43e27128ce92e08..9a9663970877b54818d32a5c5474985dcc1573c3 100644 (file)
@@ -26,63 +26,32 @@ define Package/libevent
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Event notification library
-  DESCRIPTION:=Event notification library for event-driven network servers.\\\
-    The libevent API provides a mechanism to execute a callback function \\\
-    when a specific event occurs on a file descriptor or after a timeout \\\
-    has been reached. Furthermore, libevent also support callbacks due \\\
-    to signals or regular timeouts.\\\
-    \\\
-    libevent is meant to replace the event loop found in event driven \\\
-    network servers. An application just needs to call event_dispatch() \\\
-    and then add or remove events dynamically without having to change \\\
-    the event loop.
+  DESCRIPTION:=\
+       The libevent API provides a mechanism to execute a callback function \\\
+       when a specific event occurs on a file descriptor or after a timeout \\\
+       has been reached. Furthermore, libevent also support callbacks due \\\
+       to signals or regular timeouts.\\\
+       \\\
+       libevent is meant to replace the event loop found in event driven \\\
+       network servers. An application just needs to call event_dispatch() \\\
+       and then add or remove events dynamically without having to change \\\
+       the event loop.
   URL:=http://www.monkey.org/~provos/libevent/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libevent/install
-       install -d -m0755 $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-$(PKG_VERSION).so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/event.h $(STAGING_DIR)/usr/include/
@@ -98,4 +67,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libevent-$(PKG_VERSION).so*
 endef
 
+define Package/libevent/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-$(PKG_VERSION).so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libevent))