net/quagga-unstable: fix compile issue on FreeBSD 8.1
[openwrt/svn-archive/archive.git] / libs / libevent / Makefile
index 38aebe4b8845d05cad2664eb93707e03d21abeb4..de7f327c4873ca68c1d4490cb4b26ac3b56650f5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libevent
-PKG_VERSION:=1.4.9
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.13
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable.tar.gz
 PKG_SOURCE_URL:=http://www.monkey.org/~provos/
-PKG_MD5SUM:=5154fd4582d64077d6b17851f04d6957
+PKG_MD5SUM:=0b3ea18c634072d12b3c1ee734263664
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +30,14 @@ define Package/libevent
 endef
 
 define Package/libevent/description
-       The libevent API provides a mechanism to execute a callback function 
-       when a specific event occurs on a file descriptor or after a timeout 
-       has been reached. Furthermore, libevent also support callbacks due 
+       The libevent API provides a mechanism to execute a callback function
+       when a specific event occurs on a file descriptor or after a timeout
+       has been reached. Furthermore, libevent also support callbacks due
        to signals or regular timeouts.
-       
-       libevent is meant to replace the event loop found in event driven 
-       network servers. An application just needs to call event_dispatch() 
-       and then add or remove events dynamically without having to change 
+
+       libevent is meant to replace the event loop found in event driven
+       network servers. An application just needs to call event_dispatch()
+       and then add or remove events dynamically without having to change
        the event loop.
 endef
 
@@ -47,13 +51,11 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)" \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent.{la,a,so} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libevent-1.4.so* $(1)/usr/lib/
 endef