Update libexif to 0.6.16 (#3603)
[openwrt/svn-archive/archive.git] / libs / libexif / Makefile
index a4ff381b5dff7c223b44da30d3fd2a9f654cbce6..4105a989134852213765b09855aea594e4972721 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libexif
-PKG_VERSION:=0.6.13
+PKG_VERSION:=0.6.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/libexif
-PKG_MD5SUM:=1b1e2b495c5aa20c08725f30545a110b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=deee153b1ded5a944ea05d041d959eca
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +25,12 @@ define Package/libexif
   URL:=http://libexif.sourceforge.net/
 endef
 
+define Package/libexif/description
+  libexif is a library for parsing, editing, and saving EXIF data. It is
+  intended to replace lots of redundant implementations in command-line
+  utilities and programs with GUIs.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -38,6 +41,8 @@ define Build/Configure
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \