[package] update libexif to 0.6.17 (#5406)
[openwrt/svn-archive/archive.git] / libs / libexif / Makefile
index 0cf6438ab1e3d54618187e9b26cc97b4ff15dfef..ebfe1cff93f1c597f37fdd7e0a69d30e670764b9 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libexif
-PKG_VERSION:=0.6.16
+PKG_VERSION:=0.6.17
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/libexif
-PKG_MD5SUM:=deee153b1ded5a944ea05d041d959eca
+PKG_MD5SUM:=f7cf4e623a48c9a3b13f7f95f0a41015
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -49,9 +49,9 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libexif $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexif*.{a,so*} $(1)/usr/lib/
 endef