[packages] libgcrypt: autoreconf is broken with this package, use patch-libtool fixup
[openwrt/svn-archive/archive.git] / libs / libgcrypt / Makefile
index 0ec930c82d8198c64f4ac7e20f6ee98cf27bf9c4..181cb92472d77859a63fbdbfcc53b0b3897e325e 100644 (file)
@@ -1,24 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2005-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgcrypt
-PKG_VERSION:=1.2.3
+PKG_VERSION:=1.5.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://ftp.gnupg.org/gcrypt/libgcrypt/
-PKG_MD5SUM:=49810175ab672b19a02509d2a670b156
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt
+PKG_MD5SUM:=693f9c64d50c908bc4d6e01da3ff76d8
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=patch-libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,48 +26,40 @@ define Package/libgcrypt
   CATEGORY:=Libraries
   DEPENDS:=+libgpg-error
   TITLE:=GNU crypto library
-  DESCRIPTION:=\
-       This is a general purpose cryptographic library based on the code from \\\
-       GnuPG. It provides functions for all cryptograhic building blocks: \\\
-       symmetric ciphers (AES, DES, Blowfish, CAST5, Twofish, Arcfour), hash \\\
-       algorithms (MD4, MD5, RIPE-MD160, SHA-1, TIGER-192), MACs (HMAC for all \\\
-       hash algorithms), public key algorithms (RSA, ElGamal, DSA), large \\\
-       integer functions, random numbers and a lot of supporting functions.
   URL:=http://directory.fsf.org/security/libgcrypt.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-asm \
-               --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
-       )
+define Package/libgcrypt/description
+ This is a general purpose cryptographic library based on the code from
+ GnuPG. It provides functions for all cryptograhic building blocks:
+ symmetric ciphers (AES, DES, Arcfour, CAST5), hash algorithms (MD5, SHA-1,
+ RIPE-MD160, SHA-224/256, SHA-384/512), MACs (HMAC for all hash
+ algorithms), public key algorithms (RSA, DSA), large integer functions,
+ random numbers and a lot of supporting functions. Some algorithms have
+ been disabled to reduce size (Blowfish, Twofish, Serpent,
+ RC2, SEED, Camellia, CRC, MD4, TIGER-192, Whirlpool, ElGamal, ECC).
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-asm \
+       --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
+       --enable-digests="md5 rmd160 sha1 sha256 sha512" \
+       --enable-ciphers="arcfour des aes cast5" \
+       --enable-pubkey-ciphers="rsa dsa"
 
-define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(STAGING_DIR)/usr/bin/
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{a,so*} $(STAGING_DIR)/usr/lib/
-       mkdir -p $(STAGING_DIR)/usr/share/aclocal
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(STAGING_DIR)/usr/share/aclocal/
-endef
+TARGET_CFLAGS += $(FPIC)
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/libgcrypt-config \
-               $(STAGING_DIR)/usr/include/gcrypt*.h \
-               $(STAGING_DIR)/usr/lib/libgcrypt.{a,so*} \
-               $(STAGING_DIR)/usr/share/aclocal/libgcrypt.m4
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{la,a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(1)/usr/share/aclocal/
+       $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/libgcrypt-config
+       $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/libgcrypt-config
+       ln -sf $(STAGING_DIR)/usr/bin/libgcrypt-config $(2)/bin/
 endef
 
 define Package/libgcrypt/install