[packages] libgcrypt: autoreconf is broken with this package, use patch-libtool fixup
[openwrt/svn-archive/archive.git] / libs / libgcrypt / Makefile
index 4158f641af1d32d0d95f7c24fb769153b4b0e842..181cb92472d77859a63fbdbfcc53b0b3897e325e 100644 (file)
@@ -1,22 +1,23 @@
 #
-# Copyright (C) 2005-2008 OpenWrt.org
+# Copyright (C) 2005-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgcrypt
-PKG_VERSION:=1.4.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.5.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt/
-PKG_MD5SUM:=26703ecef4bbe113b8e6a87572b80b32
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt
+PKG_MD5SUM:=693f9c64d50c908bc4d6e01da3ff76d8
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=patch-libtool
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,33 +30,29 @@ define Package/libgcrypt
 endef
 
 define Package/libgcrypt/description
- This is a general purpose cryptographic library based on the code from 
- GnuPG. It provides functions for all cryptograhic building blocks: 
- symmetric ciphers (AES, DES, Arcfour), hash algorithms (MD5, SHA-1,
+ This is a general purpose cryptographic library based on the code from
+ GnuPG. It provides functions for all cryptograhic building blocks:
+ symmetric ciphers (AES, DES, Arcfour, CAST5), hash algorithms (MD5, SHA-1,
  RIPE-MD160, SHA-224/256, SHA-384/512), MACs (HMAC for all hash
  algorithms), public key algorithms (RSA, DSA), large integer functions,
  random numbers and a lot of supporting functions. Some algorithms have
- been disabled to reduce size (Blowfish, CAST5, Twofish, Serpent,
+ been disabled to reduce size (Blowfish, Twofish, Serpent,
  RC2, SEED, Camellia, CRC, MD4, TIGER-192, Whirlpool, ElGamal, ECC).
 endef
 
-CONFIGURE_ARGS+= \
+CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --disable-asm \
        --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
        --enable-digests="md5 rmd160 sha1 sha256 sha512" \
-       --enable-ciphers="arcfour des aes" \
-       --enable-pubkey-ciphers="rsa dsa" \
+       --enable-ciphers="arcfour des aes cast5" \
+       --enable-pubkey-ciphers="rsa dsa"
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_CFLAGS += $(FPIC)
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
+       $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{la,a,so*} $(1)/usr/lib/