packages: Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt/svn-archive/archive.git] / libs / libgpg-error / Makefile
index 5b20c0e16e75fec80fb3d11324180fc4c241ad03..a2d9d90b3417c30233ec9732b284510c61f0e2e6 100644 (file)
@@ -18,7 +18,6 @@ PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error/ \
        http://gulus.usherbrooke.ca/pub/appl/GnuPG/libgpg-error/ \
        http://gnupg.unixmexico.org/ftp/libgpg-error/
 PKG_MD5SUM:=ff409db977e4a4897aa09ea420a28a2f
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -29,15 +28,17 @@ define Package/libgpg-error
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=GnuPG error handling helper library
-  DESCRIPTION:=\
-       An helper library for common error codes and descriptions.\\\
-       This is a library that defines common error values for all GnuPG \\\
-       components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt, \\\
-       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the \\\
-       future.
   URL:=http://www.gnupg.org/related_software/libgpg-error/
 endef
 
+define Package/libgpg-error/description
+       An helper library for common error codes and descriptions.
+       This is a library that defines common error values for all GnuPG 
+       components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt, 
+       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the 
+       future.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -54,7 +55,7 @@ endef
 
 define Build/InstallDev
        mkdir -p $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gpg-error-config $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg-error-config $(1)/usr/bin/
        mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gpg-error.h $(1)/usr/include/
        mkdir -p $(1)/usr/lib