packages: Update s-lang library to 2.2.4
[openwrt/svn-archive/archive.git] / libs / libgpg-error / Makefile
index 7d0844e332bbac24ab0c5941dba1209591ddbe8d..f60a9721a390d8d0f805371d1f1e35ca3a01d8fd 100644 (file)
@@ -1,26 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2005-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgpg-error
-PKG_VERSION:=1.0
+PKG_VERSION:=1.9
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error/ \
-       http://mirrors.rootmode.com/ftp.gnupg.org/libgpg-error/ \
-       http://gulus.usherbrooke.ca/pub/appl/GnuPG/libgpg-error/ \
-       http://gnupg.unixmexico.org/ftp/libgpg-error/
-PKG_MD5SUM:=ff409db977e4a4897aa09ea420a28a2f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgpg-error
+PKG_MD5SUM:=521b98aa9395e7eaf0ef2236233a0796
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,40 +30,50 @@ endef
 
 define Package/libgpg-error/description
        An helper library for common error codes and descriptions.
-       This is a library that defines common error values for all GnuPG 
-       components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt, 
-       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the 
+       This is a library that defines common error values for all GnuPG
+       components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
+       Libksba, DirMngr, Pinentry, SmartCard Daemon and possibly more in the
        future.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gpg-error-config $(1)/usr/bin/
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gpg-error.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgpg-error.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/share/aclocal
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/gpg-error.m4 $(1)/usr/share/aclocal/
+       $(INSTALL_DIR) $(2)/bin $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/gpg-error-config \
+               $(2)/bin/
+       $(SED) \
+               's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
+               $(2)/bin/gpg-error-config
+       ln -sf $(STAGING_DIR)/host/bin/gpg-error-config $(1)/usr/bin/gpg-error-config
+
+       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/gpg-error.h \
+               $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgpg-error.{la,a,so*} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/share/aclocal
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/share/aclocal/gpg-error.m4 \
+               $(1)/usr/share/aclocal/
 endef
 
 define Package/libgpg-error/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgpg-error.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgpg-error.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libgpg-error))