[packages] tar: Update to v1.22 (closes #5667)
[openwrt/svn-archive/archive.git] / libs / libgphoto2 / Makefile
index 0883759142c321233a1cd8edbc4db0b0f5ef1c5b..b3545c1ae50755783efeec59ebb1a1fa44eb9980 100644 (file)
@@ -1,27 +1,24 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgphoto2
-PKG_VERSION:=2.3.1
+PKG_VERSION:=2.4.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
-PKG_MD5SUM:=37f85e34e5b6031ddf6cac8b8782ac4f
+PKG_MD5SUM:=f55c95b676023368317e1e867397e62c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-
 define Package/libgphoto2/Default
   SECTION:=libs
   CATEGORY:=Libraries
@@ -41,25 +38,25 @@ define Package/libgphoto2-drivers
   TITLE:=Gphoto2 drivers for various cameras
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-rpath \
-               --with-drivers=all \
-               --without-included-ltdl \
-               --without-libiconv-prefix \
-               --without-libintl-prefix \
-               , \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libiconv/include" \
-               LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
-               LIBEXIF_CFLAGS="$$$$CPPFLAGS" \
-               LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
-               LIBUSB_CFLAGS="$$$$CPPFLAGS" \
-               LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
-               LIBS="-lltdl" \
-       )
-endef
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --with-drivers=all \
+       --without-included-ltdl \
+       --without-libiconv-prefix \
+       --without-libintl-prefix \
+
+CONFIGURE_VARS += \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libiconv/include" \
+       LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
+       LIBEXIF_CFLAGS="$$$$CPPFLAGS" \
+       LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
+       LIBUSB_CFLAGS="$$$$CPPFLAGS" \
+       LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
+       LIBS="-lltdl" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -83,14 +80,6 @@ define Build/InstallDev
        rm -f $(1)/usr/include/gphoto2/gphoto2
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/bin/gphoto2-config \
-               $(STAGING_DIR)/usr/bin/gphoto2-port-config \
-               $(STAGING_DIR)/usr/include/gphoto2* \
-               $(STAGING_DIR)/usr/lib/libgphoto*.{a,so*}
-endef
-
 define Package/libgphoto2/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgphoto2{,_port}.so.* $(1)/usr/lib/