cleanup
[openwrt/svn-archive/archive.git] / libs / libgphoto2 / Makefile
index a416eb8cfd5dfe896252f7fc117b4fc0601f037d..d7738d7a3c8cad057cd933fb22bc4ed750a9a15c 100644 (file)
@@ -31,7 +31,7 @@ endef
 
 define Package/libgphoto2
   $(call Package/libgphoto2/Default)
-  DEPENDS:=+libusb +libexif +libjpeg +libpthread
+  DEPENDS:=+libusb +libexif +libjpeg +libpthread +libltdl
   TITLE:=The basic library of the gphoto2 program.
   MENU:=1
 endef
@@ -42,17 +42,6 @@ define Package/libgphoto2-drivers
   TITLE:=Gphoto2 drivers for various cameras
 endef
 
-BIG_ENDIAN:=no
-ifeq ($(ARCH),mips)
-  BIG_ENDIAN:=yes
-endif
-ifeq ($(ARCH),armeb)
-  BIG_ENDIAN:=yes
-endif
-ifeq ($(ARCH),powerpc)
-  BIG_ENDIAN:=yes
-endif
-
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -69,8 +58,6 @@ define Build/Configure
                LIBUSB_CFLAGS="$$$$CPPFLAGS" \
                LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
                LIBS="-lltdl" \
-               ac_cv_c_gettext_without_libintl=yes \
-               ac_cv_c_bigendian=$(BIG_ENDIAN) \
        )
 endef