Update iodine to 0.4.2 (#3877)
[openwrt/svn-archive/archive.git] / libs / libgssapi / Makefile
index 02fed6f152c33a197820d4ebe7d5b74808f02066..319d8224f8218b4d73262212b73346ff8f3d8ef9 100644 (file)
@@ -22,11 +22,14 @@ define Package/libgssapi
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=required libraries for the nfs-utils
-  DESCRIPTION:= Support libraries - for newer nfs mount command (nfs4)
   URL:=http://www.citi.umich.edu/projects/nfsv4/linux
 endef
 
-TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
+define Package/libgssapi/description
+ Support libraries - for newer nfs mount command (nfs4)
+endef
+
+TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib $(FPIC)
 
 MAKE_FLAGS += \
        OPT="$(TARGET_CFLAGS)" \
@@ -43,11 +46,4 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgssapi.pc $(1)/usr/lib/pkgconfig
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/gssglue \
-               $(STAGING_DIR)/usr/lib/libgssapi.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libgssapi.pc
-endef
-
 $(eval $(call BuildPackage,libgssapi))