[packages] libdlna: fix build failure introduced by [21056], restore fix from [12678...
[openwrt/svn-archive/archive.git] / libs / libid3tag / Makefile
index d21ef5f1c1eedfbec0d90691ce209711b034f939..744e05b675bebcc564ff0df9651e8feb59f4b83f 100644 (file)
@@ -1,21 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libid3tag
 PKG_VERSION:=0.15.1b
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad
 PKG_MD5SUM:=e5808ad997ba32c498803822078748c3
 
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libid3tag
@@ -31,6 +33,8 @@ define Package/libid3tag/description
        ID3v1 and the various versions of ID3v2.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -40,16 +44,10 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/id3tag.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libid3tag.{a,so*} $(1)/usr/lib/
 endef