[packages] libidn: update to 1.18
[openwrt/svn-archive/archive.git] / libs / libidn / Makefile
index d61506f18178219991e486251e90b3413d36e430..6f143ed18324bd705268dc46db37fbddda8184f3 100644 (file)
@@ -1,19 +1,22 @@
-# Copyright (C) 2009 OpenWrt.org
+#
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libidn
-PKG_VERSION:=1.12
+PKG_VERSION:=1.18
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/libidn
-PKG_MD5SUM:=49db2165868d3ec2af00e0b7d0924dd8
+PKG_MD5SUM:=66f115347439f56386f37a3ad92c1da2
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,30 +27,25 @@ define Package/libidn
   URL:=http://www.gnu.org/software/libidn/
 endef
 
-define Package/libgmp/description
+define Package/libidn/description
   GNU Libidn is a fully documented implementation of the Stringprep,
   Punycode and IDNA specifications. Libidn's purpose is to encode and
   decode internationalized domain names.
 endef
 
 TARGET_CFLAGS += $(FPIC)
-CONFIGURE_VARS += CC="$(TARGET_CROSS)gcc"
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CC="$(TARGET_CC)" \
-               all install \
-       )
-endef
+MAKE_FLAGS += \
+       CC="$(TARGET_CC)" \
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.{a,so*} $(1)/usr/lib/
 endef