use Build/Configure/Default macro, Makefile cleanup
[openwrt/svn-archive/archive.git] / libs / libmad / Makefile
index 713a433ab6122deeb08377ffe430d6fcf238f3c7..1affa3360d940625a05539549ed401be74d2fd10 100644 (file)
@@ -12,87 +12,53 @@ PKG_NAME:=libmad
 PKG_VERSION:=0.15.1b
 PKG_RELEASE:=1
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
 PKG_MD5SUM:=1be543bc30c56fb6bea1d7bf6a64e66c
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 FPM:=default
 ifeq ($(ARCH),i386)
-FPM:=intel
+  FPM:=intel
 endif
 ifeq ($(ARCH),mipsel)
-FPM:=mips
+  FPM:=mips
 endif
 
 define Package/libmad
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An high-quality MPEG audio decoding library
-  DESCRIPTION:=An high-quality MPEG audio decoding library.\\\
-    MAD is a high-quality MPEG audio decoder. It currently supports \\\
-    MPEG-1 and the MPEG-2 extension to lower sampling frequencies, \\\
-    as well as the de facto MPEG 2.5 format. All three audio layers - \\\
-    Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
+  DESCRIPTION:=\
+       MAD is a high-quality MPEG audio decoder. It currently supports \\\
+       MPEG-1 and the MPEG-2 extension to lower sampling frequencies, \\\
+       as well as the de facto MPEG 2.5 format. All three audio layers - \\\
+       Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
   URL:=http://www.underbit.com/products/mad/
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(strip $(TARGET_CFLAGS))" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --enable-fpm=$(FPM) \
-                       --disable-debugging \
-                       --enable-speed \
-       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --enable-fpm="$(FPM)" \
+               --disable-debugging \
+               --enable-speed \
+       )
 endef
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/libmad/install
-       install -m0755 -d $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmad.so.* $(1)/usr/lib/
-endef
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/mad.h $(STAGING_DIR)/usr/include/
@@ -106,4 +72,9 @@ define Build/UninstallDev
                $(STAGING_DIR)/usr/lib/libmad.{a,so*}
 endef
 
+define Package/libmad/install
+       install -d -m0755 $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmad.so.* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,libmad))