[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / libs / libmad / Makefile
index c5768705cffe30f55206cd7f8254359298ef14c6..318519c0c2357207d590b5dcd47181a8f554b6cf 100644 (file)
@@ -1,25 +1,22 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmad
 PKG_VERSION:=0.15.1b
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
        ftp://ftp.mars.org/pub/mpeg/
 PKG_MD5SUM:=1be543bc30c56fb6bea1d7bf6a64e66c
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -38,39 +35,35 @@ define Package/libmad
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=An high-quality MPEG audio decoding library
-  DESCRIPTION:=\
-       MAD is a high-quality MPEG audio decoder. It currently supports \\\
-       MPEG-1 and the MPEG-2 extension to lower sampling frequencies, \\\
-       as well as the de facto MPEG 2.5 format. All three audio layers - \\\
-       Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
   URL:=http://www.underbit.com/products/mad/
 endef
 
-CONFIGURE_ARGS += \
-       --enable-shared \
-       --enable-static \
-       --enable-fpm="$(FPM)" \
-       --disable-debugging \
-       --enable-speed \
+define Package/libmad/description
+       MAD is a high-quality MPEG audio decoder. It currently supports 
+       MPEG-1 and the MPEG-2 extension to lower sampling frequencies, 
+       as well as the de facto MPEG 2.5 format. All three audio layers - 
+       Layer I, Layer II, and Layer III (i.e. MP3) - are fully implemented.
+endef
 
-MAKE_FLAGS += \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --enable-fpm="$(FPM)" \
+               --disable-debugging \
+               --enable-speed \
+       )
+endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/mad.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmad.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/mad.h \
-               $(STAGING_DIR)/usr/lib/libmad.{a,so*}
-endef
-
 define Package/libmad/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmad.so.* $(1)/usr/lib/