Cleanup the saved_builtin_dir mess. Fixes that the xserver crashed when it was
[openwrt/svn-archive/archive.git] / libs / libmcrypt / Makefile
index 8ed6475e2a3559128fc75957bf88dee06f135f81..112e53b36e5664396ba78e341e375cf38ae0c133 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,9 +15,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mcrypt
 PKG_MD5SUM:=b1be163143f8e8ed0474beeb642b3bad
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libmcrypt
@@ -40,6 +36,8 @@ define Build/Configure
        )
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -57,13 +55,6 @@ define Build/InstallDev
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/libmcrypt-config
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/mcrypt.h \
-               $(STAGING_DIR)/usr/lib/libmcrypt.{a,so*} \
-               $(STAGING_DIR)/usr/bin/libmcrypt-config
-endef
-
 define Package/libmcrypt/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmcrypt.so.* $(1)/usr/lib/