replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / libs / libmcrypt / Makefile
index 77de1fc7336fc370baff5ba1fcc6d481345a301a..8e53eebe27066a8271eb8b2e44f43185b9caf68d 100644 (file)
@@ -64,7 +64,7 @@ define Build/UninstallDev
 endef
 
 define Package/libmcrypt/install
 endef
 
 define Package/libmcrypt/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmcrypt.so.* $(1)/usr/lib/
 endef
 
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmcrypt.so.* $(1)/usr/lib/
 endef