[backfire/packages] libmicrohttpd: merge [28434]
[openwrt/svn-archive/archive.git] / libs / libmicrohttpd / Makefile
index f8bdafd6e6f7a2932a2971e1978d8195a1d5e3be..85d9c1458defd055e4c413ef7c86528ea3e59e09 100644 (file)
@@ -9,8 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmicrohttpd
 PKG_VERSION:=0.4.4
-
-ftp://ftp.gnu.org/gnu/libmicrohttpd/libmicrohttpd-0.4.4.tar.gz
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/libmicrohttpd
@@ -26,22 +25,29 @@ define Package/libmicrohttpd
   CATEGORY:=Libraries
   TITLE:=Microhttpd
   URL:=http://www.gnu.org/software/libmicrohttpd
+  DEPENDS:=+libpthread
 endef
 
 define Package/libmicrohttpd/description
  GNU libmicrohttpd is a small C library that is supposed to make it easy to run an HTTP server as part of another application.
 endef
 
+CONFIGURE_ARGS+= \
+       --disable-curl \
+       --disable-https \
+
 define Build/InstallDev 
-       $(INSTALL_DIR) $(1)/usr/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmicrohttpd.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/microhttpd.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmicrohttpd.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmicrohttpd.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libmicrohttpd/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmicrohttpd.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmicrohttpd.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libmicrohttpd))