[packages] libiconv-full: autoreconf is broken with this package, use patch-libtool...
[openwrt/svn-archive/archive.git] / libs / libmms / Makefile
index 6742b437d3efdd0cdb491ffef3803ed78caabb8f..4c822ec25dc3ae42281d143be2637ebbe0dfee94 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,24 +8,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmms
-PKG_VERSION:=0.5
+PKG_VERSION:=0.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://code.launchpad.net/libmms/trunk/$(PKG_VERSION)/+download/
-PKG_MD5SUM:=cf83053ec891f14e73a04c84d9de08ee
+PKG_SOURCE_URL:=@SF/libmms
+PKG_MD5SUM:=650ad04a4c8bd79246390b81b29680b6
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
 
 define Package/libmms
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+glib2
   TITLE:=MMS stream protocol library
-  URL:=https://launchpad.net/libmms
+  URL:=http://libmms.sourceforge.net
 endef
 
 define Package/libmms/description
@@ -36,9 +37,6 @@ define Package/libmms/description
 endef
 
 TARGET_CFLAGS += $(FPIC)
-TARGET_LDFLAGS += \
-       -L$(STAGING_DIR)/usr/lib/libintl/lib \
-       -L$(STAGING_DIR)/usr/lib/libiconv/lib
 
 define Build/Configure
        (cd $(PKG_BUILD_DIR); ./autogen.sh );
@@ -50,7 +48,10 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libmms $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmms.{a,so*} $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig
 endef
 
 define Package/libmms/install