libmpd: Enable parallel build
[openwrt/svn-archive/archive.git] / libs / libmpd / Makefile
index 24fee43b41b67d0ce1e609e3e131834dc867e1d9..b662df27a270d92038152131d694b490b4c1b4e1 100644 (file)
@@ -1,54 +1,53 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libmpd
-PKG_VERSION:=0.14.0
-PKG_RELEASE:=1
+PKG_VERSION:=0.19.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.neophob.com/files/owrt/
-PKG_MD5SUM:=44f9e0e3bcaf205b9a0d86cbcca03f9f
+PKG_SOURCE_URL:=http://download.sarine.nl/Programs/gmpc/$(PKG_VERSION)/
+PKG_MD5SUM:=a994f5f25a22c778926a3684c3e3050d
+
+PKG_FIXUP:=libtool
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
+
 define Package/libmpd
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=Libmpd is an a library to easily connect to a mpd server.
-  URL:=http://sarine.nl/libmpd
+  DEPENDS:=+glib2
+  TITLE:=Libmpd is an a library to easily connect to a mpd server
+  URL:=http://gmpc.wikia.com/wiki/LIBMPD_RELEASES
 endef
 
 define Package/libmpd/description
 It's wraps around libmpdclient and provides a higher level api.
 endef
 
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef                  
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libmpd $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libmpd-1.0 $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmpd.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libmpd.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libmpd/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libmpd.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libmpd.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libmpd))