cleanup
[openwrt/svn-archive/archive.git] / libs / libnet-1.0.x / Makefile
index 2161e5ef7a3333fc045faef73b6e0fd6c4d3b4e3..66814b16bd36d69df89b041e77720897825206af 100644 (file)
@@ -46,16 +46,16 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes \
-               , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
+               --with-pf_packet=yes, \
                ac_cv_libnet_endianess=$(ENDIANESS) \
+               ac_libnet_have_pf_packet=yes \
        )
 endef
 
 define Build/Compile
+       # pass CFLAGS again to override -O2 set by configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef