fix build where host and target arches are abi compatible (closes: #2411)
[openwrt/svn-archive/archive.git] / libs / libnet-1.0.x / Makefile
index 9a125200cdb55397001795756f7a33e15d98104b..6b70b6577e4bf3a2017faa273ad255128dc3daee 100644 (file)
@@ -35,6 +35,16 @@ ifeq ($(CONFIG_BIG_ENDIAN),y)
   ENDIANESS:=big
 endif
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --with-pf_packet=yes
+
+CONFIGURE_VARS += \
+       ac_cv_libnet_endianess=$(ENDIANESS) \
+       ac_libnet_have_pf_packet=yes \
+       LL_INT_TYPE=sockpacket
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -43,15 +53,7 @@ define Build/Configure
                Makefile.in \
                configure \
        );
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --with-pf_packet=yes \
-               , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
-               ac_cv_libnet_endianess=$(ENDIANESS) \
-       )
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
@@ -76,7 +78,7 @@ define Build/UninstallDev
 endef
 
 define Package/libnet0/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
 endef