Add firmwarehotplug (#1094)
[openwrt/svn-archive/archive.git] / libs / libnet-1.1.x / Makefile
index 5eb9904ac3d334c9ee47830b76447175b407e242..057cc6060d7e829b5657ac87f3b2d9b8c92d9724 100644 (file)
@@ -46,11 +46,9 @@ define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes \
-               , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
+               --with-pf_packet=yes, \
                ac_cv_libnet_endianess=$(ENDIANESS) \
+               ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
        )
 endef
@@ -75,7 +73,7 @@ define Build/UninstallDev
 endef
 
 define Package/libnet1/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
 endef