Fix compilation when modules are selected or not, should fix buildbot spam :p
[openwrt/svn-archive/archive.git] / libs / libnet-1.1.x / Makefile
index 0b19c1a4a53a64b341309c13ee1bec14bff84193..a8c204095a0416b3e569caeac228a0b298eab30c 100644 (file)
@@ -31,13 +31,7 @@ define Package/libnet1
 endef
 
 ENDIANESS:=lil
-ifeq ($(ARCH),mips)
-  ENDIANESS:=big
-endif
-ifeq ($(ARCH),armeb)
-  ENDIANESS:=big
-endif
-ifeq ($(ARCH),powerpc)
+ifeq ($(CONFIG_BIG_ENDIAN),y)
   ENDIANESS:=big
 endif
 
@@ -54,9 +48,8 @@ define Build/Configure
                --enable-static \
                --with-pf_packet=yes \
                , \
-               ac_libnet_have_pf_packet=yes \
-               ac_cv_lbl_unaligned_fail=no \
                ac_cv_libnet_endianess=$(ENDIANESS) \
+               ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
        )
 endef
@@ -81,7 +74,7 @@ define Build/UninstallDev
 endef
 
 define Package/libnet1/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
 endef