fix gmediaserver compile
[openwrt/svn-archive/archive.git] / libs / libnet-1.1.x / Makefile
index 192897b740c609497e32471a65c229b09b037861..a8c204095a0416b3e569caeac228a0b298eab30c 100644 (file)
@@ -36,10 +36,18 @@ ifeq ($(CONFIG_BIG_ENDIAN),y)
 endif
 
 define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.in \
+               include.m4 \
+               aclocal.m4 \
+               Makefile.in \
+               configure \
+       );
        $(call Build/Configure/Default, \
                --enable-shared \
                --enable-static \
-               --with-pf_packet=yes, \
+               --with-pf_packet=yes \
+               , \
                ac_cv_libnet_endianess=$(ENDIANESS) \
                ac_libnet_have_pf_packet=yes \
                ac_libnet_have_packet_socket=yes \
@@ -66,7 +74,7 @@ define Build/UninstallDev
 endef
 
 define Package/libnet1/install
-       install -m0755 -d $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
 endef