[package] update libnfnetlink to 0.0.41, cleanup whitespaces (#5383)
[openwrt/svn-archive/archive.git] / libs / libnfnetlink / Makefile
index 59376fe8d48bcd1c46cbad4ab4695817b9edb0ee..f704d19e8ee69e3e88cd44392ea4600b894f6848 100644 (file)
@@ -1,23 +1,20 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
-PKG_VERSION:=0.0.38
-PKG_RELEASE:=0
+PKG_VERSION:=0.0.41
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/libnfnetlink/
-PKG_MD5SUM:=014aa52e39f2b8f296a307ba712ba3c1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/libnfnetlink/ \
+       http://mirrors.evolva.ro/netfilter.org/libnfnetlink/
+PKG_MD5SUM:=5d844ea1f557bad0364d5b85cd10c796
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,17 +22,19 @@ define Package/libnfnetlink
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=@LINUX_2_6
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=@LINUX_2_6
-  TITLE:=libnfnetlink
-  URL:=http://netfilter.org/projects/libnfnetlink/index.html
+  TITLE:=A low-level library for netfilter related kernel/userspace communication
+  URL:=http://netfilter.org/projects/libnfnetlink/
 endef
 
 define Package/libnfnetlink/description
 endef
 
 define Package/libnfnetlink/description
- libnfnetlink is is the low-level library for netfilter related kernel/userspace communication. 
- It provides a generic messaging infrastructure for in-kernel netfilter subsystems 
- (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users 
+ libnfnetlink is is the low-level library for netfilter related kernel/userspace communication.
+ It provides a generic messaging infrastructure for in-kernel netfilter subsystems
+ (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users
  and/or management tools in userspace.
 endef
 
  and/or management tools in userspace.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
@@ -47,17 +46,26 @@ define Build/Compile
                all install
 endef
 
                all install
 endef
 
-
 define Build/InstallDev
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/libnfnetlink
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h $(1)/usr/include/libnfnetlink/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h \
+               $(1)/usr/include/libnfnetlink/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfnetlink.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libnfnetlink/install
        $(INSTALL_DIR) $(1)/usr/lib
 endef
 
 define Package/libnfnetlink/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libnfnetlink))
 endef
 
 $(eval $(call BuildPackage,libnfnetlink))