[packages] Add missing libtool fixups
[openwrt/svn-archive/archive.git] / libs / libnfnetlink / Makefile
index 46f7abc34613580914f7703ec8f8c8dc31d72561..fab2d95d8c3d0497a7ea15face4f8a2f146d3e1e 100644 (file)
@@ -1,23 +1,23 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnfnetlink
-PKG_VERSION:=0.0.38
-PKG_RELEASE:=0
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/libnfnetlink/
-PKG_MD5SUM:=014aa52e39f2b8f296a307ba712ba3c1
+PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/libnfnetlink/ \
+       http://mirrors.evolva.ro/netfilter.org/libnfnetlink/
+PKG_MD5SUM:=016fdec8389242615024c529acc1adb8
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,39 +25,43 @@ define Package/libnfnetlink
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=@LINUX_2_6
-  TITLE:=libnfnetlink
-  URL:=http://netfilter.org/projects/libnfnetlink/index.html
+  TITLE:=A low-level library for netfilter related kernel/userspace communication
+  URL:=http://netfilter.org/projects/libnfnetlink/
 endef
 
 define Package/libnfnetlink/description
- libnfnetlink is is the low-level library for netfilter related kernel/userspace communication. 
- It provides a generic messaging infrastructure for in-kernel netfilter subsystems 
- (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users 
+ libnfnetlink is is the low-level library for netfilter related kernel/userspace communication.
+ It provides a generic messaging infrastructure for in-kernel netfilter subsystems
+ (such as nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their respective users
  and/or management tools in userspace.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/libnfnetlink
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink}.h $(1)/usr/include/libnfnetlink/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include/libnfnetlink
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libnfnetlink/{libnfnetlink,linux_nfnetlink,linux_nfnetlink_compat}.h \
+               $(1)/usr/include/libnfnetlink/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.{a,so*} \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnfnetlink.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libnfnetlink/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnfnetlink.so.* \
+               $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libnfnetlink))