[packages] net-snmp: Enable ipv6 support if defined globally
[openwrt/svn-archive/archive.git] / libs / libosip2 / Makefile
index b16fefd604a5ea9fddc945067223fb856a6483bd..60935144b12399b1e69111ffc40c7fd7c61d5669 100644 (file)
@@ -4,17 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libosip2
-PKG_VERSION:=2.2.0
+PKG_VERSION:=3.1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/osip
-PKG_MD5SUM:=f1237af0250c59b318bd64a59f5750ea
+PKG_MD5SUM:=7eb305608256ac2a7a27b66ce52627c8
+
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,6 +31,8 @@ define Package/libosip2description
  GNU oSIP library, a Session Initiation Protocol (SIP) implementation.
 endef
 
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS+= \
        --enable-shared \
        --enable-static \
@@ -39,15 +42,8 @@ CONFIGURE_ARGS+= \
        --enable-semaphore \
        --enable-ntimer \
 
-define Build/Configure
-       $(call Build/Configure/Default)
-       $(call libtool_disable_rpath)
-endef
-
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
-       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Build/InstallDev
@@ -59,15 +55,9 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libosip2.pc $(1)/usr/lib/pkgconfig/
 endef
 
-define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/osip{,parser}2 \
-               $(STAGING_DIR)/usr/lib/libosip{,parser}2.{a,so*} \
-               $(STAGING_DIR)/usr/lib/pkgconfig/libosip2.pc
-endef
-
 define Package/libosip2/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.so $(PKG_INSTALL_DIR)/usr/lib/libosip{,parser}2.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libosip2))