[packages] libowfat: add url, fix copyright, remove $Id$
[openwrt/svn-archive/archive.git] / libs / libowfat / Makefile
index 1ffc7fb31aa8988cfe32459f24e88df732951d38..23a8869202e642624cd8bf5e9ba42d0840642812 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -27,19 +26,19 @@ define Package/libowfat
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=reimplemented libdjb under GPL
+  URL:=http://www.fefe.de/libowfat/
 endef
 
 define Build/Configure
 endef
 
 TARGET_CFLAGS += $(FPIC)
-LOWFAT_MAKEOPTS = \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPTS="$(TARGET_CFLAGS)" \
-               DEBUG="$(DEBUG)" \
-               VERSION="$(LOWFAT_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
-               OS="Linux"
+LOWFAT_MAKEOPTS = $(TARGET_CONFIGURE_OPTS) \
+       COPTS="$(TARGET_CFLAGS)" \
+       DEBUG="$(DEBUG)" \
+       VERSION="$(LOWFAT_VERSION)" \
+       CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+       OS="Linux"
 
 # work around a nasty gcc bug
 ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
@@ -47,14 +46,14 @@ ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
 endif
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
+       $(MAKE) -C $(PKG_BUILD_DIR) $(LOWFAT_MAKEOPTS)
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include/libowfat
-       $(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
+       mkdir -p $(1)/usr/include/libowfat
+       $(CP) $(PKG_BUILD_DIR)/*.h $(1)/usr/include/libowfat
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/*.a $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,libowfat))