fix libreadline compile
[openwrt/svn-archive/archive.git] / libs / libreadline / Makefile
index 861c75973572ccd8f44b33453a01f7d6d3298c48..d12462faecd90ce7f419191b22ca35251a5c3749 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/readline
 PKG_MD5SUM:=7ee5a692db88b30ca48927a13fd60e46
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -26,16 +25,18 @@ define Package/libreadline
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Command lines edition library
-  DESCRIPTION:=\
-       The Readline library provides a set of functions for use by applications \\\
-       that allow users to edit command lines as they are typed in. Both Emacs \\\
-       and vi editing modes are available. The Readline library includes \\\
-       additional functions to maintain a list of previously-entered command \\\
-       lines, to recall and perhaps reedit those lines, and perform csh-like \\\
-       history expansion on previous commands.
   URL:=http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
 endef
 
+define Package/libreadline/description
+       The Readline library provides a set of functions for use by applications 
+       that allow users to edit command lines as they are typed in. Both Emacs 
+       and vi editing modes are available. The Readline library includes 
+       additional functions to maintain a list of previously-entered command 
+       lines, to recall and perhaps reedit those lines, and perform csh-like 
+       history expansion on previous commands.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -44,6 +45,8 @@ define Build/Configure
        )
 endef
 
+TARGET_CPPFLAGS:=-I. -I.. $(TARGET_CPPFLAGS)
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \