[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / libs / librsync / Makefile
index 02de456abead69c072211944399b4b8f8aca797f..3588904a231399d04ee908468dc2e4c390e8cb6c 100644 (file)
@@ -1,36 +1,38 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=librsync
 PKG_VERSION:=0.9.7
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/librsync
 PKG_MD5SUM:=24cdb6b78f45e0e83766903fd4f6bc84
-PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CFLAGS += $(FPIC)
+
 define Package/librsync
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=implementation of the rolling-checksum algorithm
-  DESCRIPTION:=\
-       librsync implements the rolling-checksum algorithm of remote file\\\
-       synchronization that was popularized by the rsync utility and is\\\
-       used in rproxy. This algorithm transfers the differences between 2\\\
-       files without needing both files on the same system.
+  URL:=http://librsync.sourceforge.net/
+endef
+
+define Package/librsync/description
+       librsync implements the rolling-checksum algorithm of remote file
+       synchronization that was popularized by the rsync utility and is
+       used in rproxy. This algorithm transfers the differences between 2
+       files without needing both files on the same system.
 endef
 
 define Build/Configure
@@ -40,25 +42,13 @@ define Build/Configure
        );
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/librsync{,-config}.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/librsync{,-config}.h \
-               $(STAGING_DIR)/usr/lib/librsync.{a,so*}
-endef
-
 define Package/librsync/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/librsync.so.* $(1)/usr/lib/